Problem building master with autotools

Alex Aycinena alex.aycinena at
Mon Jul 10 22:15:37 EDT 2017

On Jul 10, 2017 6:58 PM, "Sumit Bhardwaj" <bhardwajs at> wrote:

I checked out master in the AM today and had a clean build (make and make
install) on Fedora 25 using autotools. I can try again once I get to my
personal machine.

Are you doing make test here? I can try and report.


On Mon, Jul 10, 2017 at 6:38 PM, Alex Aycinena <alex.aycinena at>

> With a fresh checkout of master, I try to build with the autotools but I
> get an error in linking test-import-pending-matches with test-engine-stuff
> during make as follows:
> /usr/bin/ld:
> ../../../src/engine/test-core/.libs/libgncmod-test-engine.a(
> test-engine-stuff.o):
> undefined reference to symbol '__gxx_personality_v0@@CXXABI_1.3'
> /usr/lib64/ error adding symbols: DSO missing from command
> line
> collect2: error: ld returned 1 exit status
> Makefile:837: recipe for target 'test-import-pending-matches' failed
> I can build with cmake but I would like to run make check after an
> autotools make because I think it runs different checks.
> Can anyone give me an idea of how to get this to work? This is Fedora 25.
> Thanks,
> Alex
> _______________________________________________
> gnucash-devel mailing list
> gnucash-devel at

No - I have a new check out and an empty build directory. I run
then change to the build directory. I run config with a bunch of switches
referring back to the main directory for source. Then I run make and get
the error.

Can't figure out why it stopped working suddenly a few weeks ago.



More information about the gnucash-devel mailing list