Unstable terminates immediately

Alex Aycinena alex.aycinena at gmail.com
Fri Mar 2 15:26:27 EST 2018

On Fri, Mar 2, 2018 at 6:21 AM, John Ralls <jralls at ceridwen.us> wrote:

> > On Mar 2, 2018, at 4:03 AM, Geert Janssens <geert.gnucash at kobaltwit.be>
> wrote:
> >
> > Op vrijdag 2 maart 2018 02:21:45 CET schreef Alex Aycinena:
> >> On Thu, Mar 1, 2018 at 5:15 PM, John Ralls <johndanielralls at gmail.com>
> >>
> >> wrote:
> >>> Run it in the debugger and see where it’s crashing and why?
> >>>
> >>> Regards,
> >>> John Ralls
> >>
> >> Actually I tried that before sending the first e-mail and there was no
> >> crash and no backtrace. It simply exited during the splash screen and
> the
> >> trace file showed it couldn't find the various modules mention earlier
> in
> >> this thread. I'm going to try as a different user to see if there is
> >> something weird in my environment or anything like that.
> >>
> >> Alex
> >
> > Simply to rule F26/27 differences out I have upgraded to F27 overnight.
> It
> > still works ok here, though I do install in a subdirectory of my homedir
> > instead of /opt.
> That reminds me, Cmake handles /opt installations specially. It wants to
> install etc/gnucash/* in /etc/opt/gnucash-git/gnucash-acct-maint/gnucash/gnucash.
> That (a) fails unless you say `sudo ninja install` and (b) ensures that the
> files are in a place GnuCash will never find them.
> Try passing -DSYSCONFDIR=/opt/gnucash-git/gnucash-acct-maint/etc on the
> CMake command line.
> Regards,
> John Ralls

I did try rm -fr * .??* and it didn't make any difference (I had missed
your response because it had gone to spam).

By the way, since you are on Fedora, do you know which packages you have
installed that give you Ktoblzcheck and Gwengui-gtk3?


Based on your comments, I compared the directories of my latest build with
one on an F26 VM from last Nov which had been built with autotools and the
differences are:

with cmake, under /opt/gnucash-git/gnucash-acct-maint/ are: bin, include,
lib64, and share

with autotools, under /opt/gnucash-git/gnucash-clean/ are: bin, etc,
include, lib, libexec, and share

I tried passing -DSYSCONFDIR=/opt/gnucash-git/gnucash-acct-maint/etc on the
CMake command line but got the same result. Then I gave the gnucash-dev
user sudo privileges and did the installation with sudo but got the same

Finally, I did what Geert does and installed in a subdirectory of my home
instead of in /opt and that worked. The directories under
/home/gnucash-dev/gitcheckouts/gnucash-acct-maint-install/ are: bin, etc,
include, lib64, and share.

It had been working by installing in /opt, even after I started using
cmake, so not sure what changed suddenly but at least I'm back in business.

Thanks for all the help,


More information about the gnucash-devel mailing list