Windows Build

Geert Janssens geert.gnucash at
Sun Mar 4 11:40:08 EST 2018

Op zondag 4 maart 2018 16:19:46 CET schreef Robert Fewell:
> Hi all,
> Just tried to build the latest unstable for Windows but it fails with this
> ...
> [ 76%] Generating gnucash.appdata.xml
> C:/gcdev64/msys2/mingw32/bin/msgfmt.exe: cannot locate ITS rules for
> C:/gcdev64/gnucash/unstable/src/gnucash-git/gnucash/gnome/
> make[2]: *** [gnucash/gnome/CMakeFiles/gnucash-appdata.dir/build.make:61:
> gnucash/gnome/gnucash.appdata.xml] Error 1
> make[1]: *** [CMakeFiles/Makefile2:7919:
> gnucash/gnome/CMakeFiles/gnucash-appdata.dir/all] Error 2
> make: *** [Makefile:163: all] Error 2
> *** Error during phase build of gnucash-git: ########## Error running make
> -j 1  *** [15/17]
> Poked around but could not get it to work so thought I would see what the
> build server logs yield but that has not worked since 25/02/2018 so no help
> there.
This probably means msgfmt is not finding gettext's its rules. On linux they 
are in /usr/share/gettext/its and/or /usr/share/gettext-0.19.8/its.

I had to search a bit on the windows build server. Apparently there they are 
stored under /mingw32/share/gettext/its which for some reason is not where 
msgfmt is expecting them. We can fix this by setting environment variable 
GETTEXTDATADIR to /mingw32/share/gettext somewhere that it's in the 
environment when gnucash is being built. I don't know offhand how to do that 
exactly in jhbuild.

> So I downloaded that build but it fails with a missing
> libboost_date_time-mt.dll so if the above is fixed it still might not work.
Interesting. The build server's build failure is a gettext issue as well. It 
fails to compare GETTEXT_VERSION_STRING to 0.19. Or more precisely it seems 
like GETTEXT_VERSION_STRING is not being set.

Did you not get this error in your cmake run locally ?


> PS: Is it possible to clear out some of the old logs, maybe separate
> sub-directories for each maint, master, unstable and docs.

That should be something for Derek to look into...

> Also the maint
> build is complaining about certificates and gives up.

Hmm, looks like our download script isn't happy with the new certificate being 
used at aquamaniac.  It appears the download function we use is not smart 
enough to read Alternative DNS names from the certificate... To be 

Unless you plan to dig into these yourself, can you file bug reports ?


More information about the gnucash-devel mailing list