[GNC-dev] Help packaging GnuCash 3.x for Ubuntu Bionic

Tommy Trussell tommy.trussell at gmail.com
Mon Sep 30 00:13:33 EDT 2019

On Sun, Sep 29, 2019 at 11:46 AM Stephen M. Butler <kg7je at arrl.net> wrote:

> On 9/28/19 9:46 PM, Tommy Trussell wrote:
> > Stephen -- I got a reply on the Repositories and Backports forum:
> > https://ubuntuforums.org/showthread.php?t=2427539
> >
> ...
> > Then you can update apt in the chroot to see that the backports
> > repository is available.
> Now to figure out how to start over and remove the existing xxx-amd64
> environments.

I haven't done it yet, but it sounds fairly straightforward to blow away
the chroot


Just go to wherever they are installed, delete them, and you can create new
ones. Be sure you don't have suspended processes hanging around. I kept
having that happen until I changed the sbuild preferences so they weren't

I have been trying to follow up on my theory that the sbuild fails because
of the buggy cmake version in Bionic. I found the PPA where this guy was
trying to get them to do an SRU (Stable Release Update) to upgrade / patch
the version of cmake.


but no matter what I try I can't get the sbuild chroot to load his version

I'm using this command that SHOULD point to his PPA

$ sbuild -Avs -d bionic-amd64  --extra-repository="deb [trusted=yes] deb
bionic main"

But it doesn't seem to be loading his package no matter what I put into

SO I grabbed his package and tried to build it...

created a source directory; cd to it

$ dget

tried to sbuild...
Strangely enough that build is failing in exactly the same way. Ugh.

SO I am stymied for now. I bet it's something simple I'm not seeing because
I'm tired.

Time to rest; have an appointment tomorrow.

More information about the gnucash-devel mailing list