[GNC-dev] Fresh Windows build setup fails

John Ralls jralls at ceridwen.us
Wed Dec 23 20:31:38 EST 2020

> On Dec 23, 2020, at 6:50 AM, Robert Fewell <14ubobit at gmail.com> wrote:
> Hi,
> My Windows 10 hard drive failed which I thought would not be a big deal as
> I only use it to build and test the windows build. After installing Windows
> 10 and updating I grabbed the setup-mingw64.ps1 file and proceeded to
> recreate my build system.
> Unfortunately that did not work, tried the 32bit and 64bit versions which
> both failed. The first problem was that pkg-config --list-all would list
> all the packages with a starting forward slash with problems also in
> jhbuild.
> So tried another tact, I had an old backup from March which I restored and
> then proceeded to update but that resulted in pacman listing loads of
> missing packages in the 'virtual world'
> My last attempt was to do the script manually, all OK till line 241 where
> it installed mingw64/cmake and pkg-config. Once these were installed
> pkg-config --list-all would list with forward slash's. To overcome this I
> uninstalled them and installed msys versions and proceeded to the end of
> script.
> I have not checked the whether the boost version is correct for the webkit
> version as to start with I just wanted a valid dependency.
> Changed to the gnucash-on-windows.git directory to start the build but that
> failed as follows...
> Failed to 'import jhbuild' on line 15
>   to fix I changed line 12 to sys.path.insert(0,
> 'c:/gcdev64/src/jhbuild.git')
> Next was subprocess_win32 has no check_output
>  so added a line check_output = real_subprocess.check_output to
> subprocess_win32.py
> Which resulted in a string has no split method in systeminstall.py
>  so changed shell_split = string.split to shell_split = str.split
> I am not sure these changes are correct as I know nothing about python but
> I can now run...
> $ TARGET=gnucash-maint jhbuild -f jhbuildrc build
> Required packages:
>  System installed packages which are too old:
>    (none)
>  No matching system package installed:
>    make
>    gcrypt
>    pkg-config
>    gmp
>    git
>    boost
>    cmake
>    ninja
> The strange thing is that all these are installed as...
> cmake --version gives 3.18.4, ninja --version gives 1.10.2
> So the question is, has anybody recently done a fresh build setup install
> and it worked or know how to fix.


Are you trying to run MSYS2 commands from a CMD or Powershell window instead of from an MinGW32/64 one?

John Ralls

More information about the gnucash-devel mailing list