gnucash 1.9.1 at 13314: Multiple changes pushed

John Ralls jralls at code.gnucash.org
Mon Mar 31 00:43:45 EDT 2014


        at  https://github.com/Gnucash/gnucash/tree/b6644bd398f68b8b23f05b7903f8911ecfd929b4 (tag)
   tagging  53d4eaef5988fa805ab70d9e0420ce5521465b4e (commit)
  replaces  gnucash-1-9-0 at 13158,
 tagged by  John Ralls
        on  Mon Feb 20 03:16:26 2006 +0000


'update to release 1.9.1'

Chris Lyttle (1):
      update to release 1.9.1

Christian Neumair (16):
      Add two columns to the Accounts page: "Total (Period)" & "Balance (Period)"
      Remove forgotten unused variable.
      Move the accounting period preference functions from window-main-summarybar
      Change the reports from using a hard-coded fiscal year to using the global
      Tweak the preferences labels for accounting periods.
      gc_protect SCM reports while they are in the GHashTable.
      Gracefully handle errors in report options.
      Take #2:  Fixups for two botched gnc-plugin-page-report.c commits tonight.
      Use the price nearest to midday to get the value in the default currency.
      Don't continue to parse the expression if we've already reached the end.
      Copy 'svn log -v' output from past 20 days to ChangeLog.
      Changed balance calculations in three reports from using local
      Remove --enable-opt-style-install configure option.
      Convert the AccountType selection functions to work with GtkTreeSelections
      Use GPOINTER_TO_INT to avoid casting pointer to integer of different size.
      Fix for 'use of uninitialized' warning.

Christian Stimming (15):
      String cleanup. Remove erroneous underscore. Fixes #330769.
      Fix duplicate menu item shortcut. Fixes #330672.
      Fix duplicate menu item shortcut. Fixes #330671.
      Updated German translation - 3485 out of 3656 done.
      Add --keyword=Q_ to xgettext arguments so that translations with
      When translation potentially empty strings, check always for nonemptyness. Should avoid #330179 in the rest of the code as well.
      String cleanup; fix manual emulation of ngettext; fix some memory leaks due to g_strconcat, but not yet all
      Updated German translation - 3500 out of 3657 done.
      Updated French translation by Didier Vidal <didier-devel at 9online.fr>
      For latest aqbanking changes, define AQBANKING_NOWARN_DEPRECATED to
      Make the gconf key wordings consistent across all of our schemas
      Updated German translation - 3524 out of 3716 done.
      Make update-po because of recent massive string changes
      Fix old truncation of filename prefix that is no longer valid
      Fix uninitialized variable warning

David Hampton (25):
      Fix a duplicate accelerator key.
      Set the window type hint to normal.
      Set the busy cursor while the dialogs are being generated.
      A couple of performance enhancements.
      Call existing function to find the end of the day.
      Fix the code that updates the buy/sell action based on the number of
      Set the default button.
      Remove forgotten unused variable.
      Better fix for the code that updates the buy/sell action based on the
      Print out the installed F::Q version at startup.
      Update for known F::Q 1.11 quote sources.
      Don't initialize the display at option parsing time.  This way
      Pass argc by reference instead of value so g_option_parse_context can
      Correctly open an account and its sub-accounts. Fixes 330745.
      Globally replace the words "exchange_code" with cusip in the
      Patch from Tommi Vainikainen <tvainika at niksula.hut.fi> to remove
      Andreas Köhler's patch to wrap label text in a couple of dialogs.
      Andreas Köhler's patch to prevent crash when voiding a transaction.
      Andreas Köhler's patch to convert the account types list in the
      Prepare for gtk change that will issue warnings if the return value of
      Remove all explicit claiming of the selection in these files.  The
      Regularize the naming of the Finance::Quote auxiliary scripts. Remove
      When looking for an matching account name, start at the beginning of
      Remove unused debug code.
      Take the selection into account when handling the keypad decimal point

Derek Atkins (50):
      Print more debugging when the guile version check fails.
      Use xaccTrans{Begin,Commit}Edit in xaccTransDestroy()
      Test for an empty string when translating.  (Fixes #330179)
      added README.dependencies to the dist.  Fixes #330614.
      check that we can find g-wrap-wct.h.
      Better handling of event removal.  This allows us to actually
      don't need to scm_gc_{un,}protect_object on SCM_BOOL_F.
      set the document title properly AFTER type-str is set.
      rework the initialization to require autoconf-2.59 and automake-1.9
      Um, quote the sed script so it actually works right.  Oops.
      rename gnc:owner-get-address-dep to gnc:owner-get-name-and-address-dep
      Rework some APIs for the fancy-invoice set the client name font.  #327545.
      Brian's patch to fancy-invoice to parameterize everything.
      Des Dougan's patch to let the user choose the fancy-stylesheet image alignment.  Fixes #314048.
      Mike Alexander's Currency Scrub patch.
      Boris Zbarsky's advanced-portfolio patch. (#311549)
      Mike Alexander's patch to handle multiple currencies in reports. (#314554)
      Mike Alexander's reconcile preselection patch (#112653).
      Christian Neumair's desktop patch (#145545)
      depend on autoconf 2.59 and automake 1.9
      Error out of autogen if one of the programs fails.
      Revert advanced-portfolio.scm r13244 because it breaks the report.
      use glib macro instead of cast to convert pointer to int.  Fixes #330581.
      Andrew Sackville-West's patch to add display options and fix
      Mention libtool-ltdl-devel for FC4 if ltdl.h is missing.
      Fix a typo; forgot one procedure name-change instance.
      Small QOF build fix for dist and non-srcdir builds:
      set the document title properly.
      get --disable-gui configure switch to actually do what we want.
      combine XML_{CFLAGS,LIBS} into LIBXML2_{CLFLAGS,LIBS}
      move jsled's g-type initialization into the module init
      need g_type_init() because we don't actually "load" the file backend.
      * lib/libqof/qof/Makefile.am: add qofla-dir.h to DISTCLEANFILES
      Make the build work if the build directory is not the source
      Don't pass NULL to ferror() (from bug #143720).
      scrub the transaction for a currency after we replay. (#143720).
      Fix a double-set of CLEANFILES.
      * configure.in: remove un-needed/wanted gsf/goffice configure options
      * configure.in: autodetect OFX and use it if we find it.
      * intl-scm/xgettext.scm: remove the absolute path from filenames
      display an error dialog when we fail to parse a log file
      Also report an error dialog if the fopen() fails.
      Make sure we use tabs, not spaces, in the transaction log (#331620)
      Pop up a warning dialog if the user has no valid post-to accounts. Fixes #331730.
      Brian's patch to add company-id to the company address.
      Remember the last-used account when processing payment (#329725)
      Use glib's gi18n.h instead of redefining gettext.
      A few tests to improve get_random_query() and fix a couple test bugs.
      Don't let users post negative invoices.  (#166864)
      Phil Longstaff's patch to make the GUID length a magic number.

Joshua Sled (4):
      Fix test (init) failure.
      Andreas Kohler's patch to not scroll the tree view headers in the new-account hierarchy druid. Bug#330850.
      Implement new-hierarchy-druid placeholder-value merge policy as discussed on -devel.
      Build fix; finish removing obsolete merge "error" check.

Neil Williams (14):
      New QofBackendError code if files cannot be read
      Check that files can be opened before
      Improve QOF_TYPE_COLLECT handling and recursive copies
      Ensuring get_random_double returns at least some decimal places more often than not.
      ChangeLog for my commits today
      Fix Bug 107876 - financial calculator would call exit(1) if calculation resulted in an interest rate of zero.
      ChangeLog entry for bug 107876 fix in fin.c
      preventing data loss in normal use - retain unsigned int check for zero as a special case error state indicating immediate abort.
      make it clearer that the return value of 0.0 is an error by using g_return_val_if_fail - cannot use assert as return value needs to be modified.
      correcting the logic in the error state
      ignore generated po/stamp-it file
      Improved reference handling for recursive copying of entities - relocate disparate functions to a single new file
      updated test routine for new recursive code in libqof
      ChangeLog for reference and recursive QOF changes





More information about the gnucash-patches mailing list