libxml 1.8.13 not enough?

Adrien Beau
Fri, 24 Aug 2001 15:22:29 +0200

Hello everyone,

I've just subscribed to this list because I've had a problem
yesterday trying to compile GNUCash. I seems there has been
a mini-screwup while subscribing, so I apologize if you
receive this message twice.

I'm currently evaluating the finance managers available under
Linux, which roughly means Moneydance and GNUCash. While
Moneydance, being a Java application run in a proper and up-
to-date Java environment, had no problems to launch, GNUCash
had an error which became even more irritating as I went back
to work this morning and accessed the Net. Here is why.

Checking the dependencies of GNUCash on Slackware 8 was a
rather pleasant experience. Though GNUCash 1.6.2 was released
on August 13th - my birthday! - most of its package
requirements, when it comes to software versions, were met by
Slackware. Of course I had to install the more specific
libraries - slib, g-wrap and guppi.

I'm digressing a little bit to say that, by the way, this was
not the most pleasant experience. GNUCash's site and package
documentation don't clearly mention the dependency g-wrap has
on slib: I tried to install g-wrap first, and it initially
failed. And also, guppi, while a 1.3 MB download, used an
impressive 100 MB of disk space when compiled! But well, it
worked anyway.

Now comes the problem. I went on to finally install GNUCash
itself. However ./configure halted halfway, complaining that
one of the libxml functions was missing, and that I needed
at least libxml 1.8.3. Doh! Not a pleasant way to end the
evening! I checked and saw that Slackware only got 1.8.13,
I was tired and my brain mostly off, so I read,
cursed Slackware and went to bed.

Now, it's the end of the morning here, the Sun is shining and
pollution is drawing strange dark patterns on Paris's horizon.
My brain is back on, and I notice that libxml 1.8.13 is indeed
- or should be - better than 1.8.3.

So, how do I solve the problem? How do I make ./configure
accept my 1.8.13 libxml? Are there known problems with latest
versions of libxml? Should I try to install libxml 2.x?

Waiting for your answer, I'll download libxml 1.8.15 in the

I hope to hear from you,

Adrien Beau - -
 Mes propos n'engagent que moi et en aucun cas mes employeurs