Import Investment accounts from MSMONEY

Boyd Kelly
Tue, 22 May 2001 08:00:59 -0700

Hi Bill,

Thanks very much for you help.  I did notice a console error message
something to the effect of Unknown field RtrnCap.  I was able to change some
transactions to get rid of that, but still get my original error when
loading the qif file.  Changed the Windows regional date settings in Control
Panel to US mm/dd/yyyy, (Was set to CA in format yyyy/mm/dd), and
reexported, but no luck yet.


-----Original Message-----
[]On Behalf Of Bill Gribble
Sent: May 22, 2001 6:05 AM
To: Boyd Kelly
Subject: Re: Import Investment accounts from MSMONEY + online banking

On Mon, May 21, 2001 at 10:27:12AM -0700, Boyd Kelly wrote:
> I have tried to import my investment accounts from msmoney, but when I try
> to 'load' the qif file, i get a message:  QIF file parse failed: Data
> inconsistent in QIF file.  How do i find out what that inconsistency is?

Gnucash won't report it, but I can tell you what that error means in

Dates and numeric values can be in the QIF file in several formats,
and the qif import code has to figure out which it is.  For example,
is the date "01/02/01" Jan 2 or Feb 1?  Is the number "1,001" one
thousand one or one and one thousandth?  The answer can vary from
field to field in the file but seems to always be consistently used
for a given field in the file; for example, in many German QIF files
the share price and amount fields are in European notation
("1.000,00") but the transaction totals are American ("1,000.00").

The strategy I use is to look for "smoking guns" that tell me
unambiguously what format is being used.  For example, if I see the
date "01/02/00" I might not know what it means, but if the next date
is "01/31/00" I know that dates in this file are mm/dd/yy and 01/02/00
is Jan 2.

The error you saw is caused by conflicts between two "smoking guns"
that conflict with each other. For example, the first date in a file
is "1/31/00" and the second is "31/01/00".  That should never happen.

For numbers, the problem would be something like a number "1,000.00"
followed by "1.000,00".

With a file that size, it's going to be hard to find out exactly
what's wrong.  You might have some luck looking at the file by hand
and seeing if there's something that obviously fits the description
above; otherwise I can hack up a little patch for you to print more
info about the error (at least enough to know what field is bombing).

Bill Gribble

gnucash-user mailing list