Compiling gnucash on SuSE 9.3 (was Re: 1.8.10+ on Suse 9.3 or release import/export?)

Des Dougan des at
Mon Aug 8 00:25:34 EDT 2005

CS and Thomas,

Thanks for your help with this process.

I followed both your instructions, with one additional package - I found
I had to also install the slib-3a1-44 RPM, as the compile failed without

Following this, I ran the make and make install, both of which ran

However, I found a couple of issues:

1. gnucash was installed in /usr/bin/gnucash rather than in the gnome
tree. I used Thomas's script for the compile, although I ran as root
(I'm the only user of this PC).

2. When I ran gnucash after the compile process had completed, I got an

des at p133:~> /usr/bin/gnucash
ERROR: In procedure open-file:
ERROR: No such file or directory: "/usr/share/guile/1.6/slib/mklibcat"

The only mklibcat file I can find is /usr/share/slib/mklibcat.scm.

I'd appreciate any ideas on what's happening here.

Thanks and regards,


Des Dougan, Principal
Dougan Consulting Group

Ph: 604-980-2848       Email: des at DouganConsulting dot com     

Design - Implementation - Support

More information about the gnucash-user mailing list