Compiling gnucash on SuSE 9.3 (was Re: 1.8.10+ on Suse 9.3 or release import/export?)

Derek Atkins warlord at MIT.EDU
Mon Aug 8 04:52:15 EDT 2005

Des Dougan <des at> writes:

> 1. gnucash was installed in /usr/bin/gnucash rather than in the gnome
> tree. I used Thomas's script for the compile, although I ran as root
> (I'm the only user of this PC).

I suspect this is because it ran configure with --prefix=/usr instead of

> 2. When I ran gnucash after the compile process had completed, I got an
> error:
> des at p133:~> /usr/bin/gnucash
> ERROR: In procedure open-file:
> ERROR: No such file or directory: "/usr/share/guile/1.6/slib/mklibcat"
> The only mklibcat file I can find is /usr/share/slib/mklibcat.scm.

run gnucash as root, once.  This will cause it to build the libcat.
Then you can run it as you.

> I'd appreciate any ideas on what's happening here.
> Thanks and regards,


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL:    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-user mailing list