Compiling gnucash on SuSE 9.3 (was Re: 1.8.10+ on Suse 9.3 or release import/export?)

Des Dougan des at
Mon Aug 8 22:00:14 EDT 2005


On Mon, 2005-08-08 at 10:52 +0200, Derek Atkins wrote:
> Des Dougan <des at> writes:
> > 1. gnucash was installed in /usr/bin/gnucash rather than in the gnome
> > tree. I used Thomas's script for the compile, although I ran as root
> > (I'm the only user of this PC).
> I suspect this is because it ran configure with --prefix=/usr instead of
> --prefix=/opt/gnome

Yes, you're right. I hadn't spotted that when I looked at Thomas's

> > 2. When I ran gnucash after the compile process had completed, I got an
> > error:
> >
> > des at p133:~> /usr/bin/gnucash
> > ERROR: In procedure open-file:
> > ERROR: No such file or directory: "/usr/share/guile/1.6/slib/mklibcat"
> >
> > The only mklibcat file I can find is /usr/share/slib/mklibcat.scm.
> run gnucash as root, once.  This will cause it to build the libcat.
> Then you can run it as you.

Yes, that worked fine. Thanks for that. Is there no way the compile can
set this up?



Des Dougan, Principal
Dougan Consulting Group

Ph: 604-980-2848       Email: des at DouganConsulting dot com     

Design - Implementation - Support

More information about the gnucash-user mailing list