1.9: OFX Direct Connect

Don Levey gnucash at the-leveys.us
Thu Feb 16 22:04:55 EST 2006

Derek Atkins wrote:
> Quoting Don Levey <gnucash at the-leveys.us>:
>> Don Levey wrote:
>>> I am assuming, at this point, that I need to rebuild the aqbanking
>>> packages with the new libofx in place.  I'll do that and report
>>> back.
>>>  -Don
>> Oops, can't do that.  The aqbanking packages need the libofx-devel
>> package which wasn't built along with the other two.  I'll keep
>> pounding on this... -Don
> Why don't you take the Fedora libofx.spec and modify it to 0.8.1
> and run "make dist" in the libofx SVN tree to get a tarball?

Because that hadn't occurred to me.  However, I've now tried that and I've
got a tarball.  Clearly, though, either I didn't edit the spec file
properly, or my assumptions are incorrect.  I've tried three separate

1) I've unpacked the tarball, made sure the spec file references v0.8.1, and
tried running rpmbuild -ba <specfile>.  This, unfortunately, only gives me
libofx and libofx-debuginfo.  I did indeed take the spec file from the
libofx-0.8.0 source RPM I found on the fedora.redhat.com site, and tried to
use it against the tarball I made from CVS for libofx-0.8.1.

2) I've tried running rpmbuild -ta <tarball>.  This fails, erroring that I
don't have libofx-0.7.0-gcc4.patch.  Adding that file to the referenced
directory give me an error on that file (1 out of 1 hunk failed).

3) I've tried rpmbuild --rebuild <src rpm made from #1>.  Not surprisingly,
this gave me exactly the same results as #1.

Bottom line: I'm unable to get the libofx-devel RPM to build.


More information about the gnucash-user mailing list