Accessing GNUCash Help

Peter Pugh peter.pugh at
Mon Oct 16 05:58:26 EDT 2006


Another newbie question.

I have just installed GNUCash 2.0.2 and GNUCash-Docs 2.0.1 on a  
MacBook Pro with OS X 10.4.8.  I used the instructions and comments  
on "" to  
guide me through the process -- including building GNUCash-Docs.

GNUCash appears to run fine.  Although I am still learning how to use  

My current problem is with GNUCash-Docs ...

At first, I couldn't see any documentation using "Help -> Tutorial  
and Concepts" or "Help -> Contents".  Nor could I see anything  
through Yelp.

I re-read the Yelp ReadMe, etc, and found that I apparently needed to  
set the "OMF_DIR" in /sw/etc/scrollkeeper.conf to include "/usr/local/ 
share/omf".  And then run /sw/bin/scrollkeeper-update.  I did these  
steps and now can find the GNUCash documentation in Yelp.  Although,  
when I now run Yelp, it opens itself inumerable times -- I've counted  
40+ last time I tried, before I killed the XTerm session I ran it  

HOWEVER, I still can't see any documentation using "Help -> Tutorial  
and Concepts" or "Help -> Contents".  Can anyone guide me as to why  
this may be?  I don't get any error messages or anything, simply no  
response at all.

I have found an article using Google that indicates there used to be  
a problem  with 1.1.8 about the directory where the files were stored  
in FreeBSD having two entries for gnome in the directory path --  
I.e. .../gnome/gnome/...

 > > The FreeBSD port sets the GNOME datadir to ${PREFIX}/share/ 
gnome, so
 > > in my case it was /usr/X11R6/share/gnome.  The configure script of
 > > GnuCash sets GNC_HELPDIR to $(datadir)/gnome/help/gnucash so  
that is
 > > where the double "gnome" is coming from.  I have fixed it now.

But that doesn't seem to be applicable in my case.

I have also found statements that say GNUCash is now fully integrated  
with Yelp.  Does that mean that when I try to access "Help ->  
Tutorial and Concepts" that it should kick-off a Yelp session?  If  
so, is the fact that Yelp is installed through Fink, and is in /sw/ 
bin, whilst GNUCash was built from source and is installed in /usr/ 
local/bin, part of the problem?  Both directorys are in my PATH.

Any suggestions please?

Thank you,


More information about the gnucash-user mailing list