minor gnucash 2.0 irritation

Philippe A. futhark77 at gmail.com
Sun Oct 29 11:31:14 EST 2006

Hi Derek,

>   - When my data got imported, gnucash assumed the currency to use for
> >   all my accounts was USD because it is my user's locale. That may seem
> very
> >   obvious to all of you indeed. But the truth is my accounts are in CAD
> >   currency. I think I would be nice that when gnucash imports the data,
> it
> >   also asks what default currency to use for accounts and reports.
> > This option
> >   already exists in the preferences, and this is how I solved this
> problem.
> I'm not sure whether you mean "import from 1.8" or "import from QIF"
> or some other type of import?  If you're in Canada, why don't you set
> your locale to en_CA?

I'm referring to what happens when starting gnucash 2.0 for the first time,
with 1.8 data. There some conversion is performed and I was thinking it'd be
a good place where to ask for the default currency for accounts and reports.

It does not make so much sense anymore, except for those "mixing" locales as
I've been doing.

I didn't change locale because of a misconception I had for a very long
time. I am actually fr_CA and I avoided this locale because I thought the kb
layout was associated with the locale, and I really didn't want the cad kb
layout by default when ending up in text consoles. You just had me break
this misconception. Ain't that funny!

>   - Typed amounts are now assumed to be CENTS until the separator is
> >   found. To enter a charge of say 12$, I now have to type "12.00". In
> >   gnucash 1.8, typing "12" was sufficient. Am I the only one to be
> >   annoyed with that?
> I cannot reproduce this.  Where are you seeing this behavior?  I just
> tried in the register and also the transfer dialog, and typing "12" made
> it $12.00 and not $0.12

Try with Automatic Decimal Point enabled in Prefs->General. Maybe that's the
expected behavior after all. For my part, I'll keep that checkbox disabled.


More information about the gnucash-user mailing list