minor gnucash 2.0 irritation

Derek Atkins warlord at MIT.EDU
Sun Oct 29 10:18:15 EST 2006


Quoting "Philippe A." <futhark77 at gmail.com>:

> I have started using gnucash 2.0 yesterday. Here are two things that gave me
> a little trouble.
>   - When my data got imported, gnucash assumed the currency to use for
>   all my accounts was USD because it is my user's locale. That may seem very
>   obvious to all of you indeed. But the truth is my accounts are in CAD
>   currency. I think I would be nice that when gnucash imports the data, it
>   also asks what default currency to use for accounts and reports. 
> This option
>   already exists in the preferences, and this is how I solved this problem.

I'm not sure whether you mean "import from 1.8" or "import from QIF"
or some other type of import?  If you're in Canada, why don't you set
your locale to en_CA?

Some of the preferences are not retained from 1.8 -> 2.0.

The QIF importer will ask you for the currency IFF it's creating new
accounts.  Otherwise, yes, it assumes your locale currency.  The current
QIF importer needs to get re-written anyways.

>   - Typed amounts are now assumed to be CENTS until the separator is
>   found. To enter a charge of say 12$, I now have to type "12.00". In
>   gnucash 1.8, typing "12" was sufficient. Am I the only one to be
>   annoyed with that?

I cannot reproduce this.  Where are you seeing this behavior?  I just
tried in the register and also the transfer dialog, and typing "12" made
it $12.00 and not $0.12

> Should I bother submitting feature requests?

No.  We already know we need to rewrite the QIF importer and the latter
issue -- I cannot reproduce it on FC5.


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-user mailing list