Windows 2.2.6 Currency Updates

Fred Bone Fred.Bone at
Tue Sep 2 12:22:13 EDT 2008

On 31 August 2008 at 12:59, Housemartins said:

> Fred Bone wrote:
> > 
> > Have you run the "install online price retrieval" correctly? Have you
> > tried rerunning it? What happens?
> > 
> Yes, ok, I've re-ran it - it doesn't look like it worked, trimmed output
> follows (I accepted defaults prior to this):
> ----------------------------------->< snip >< ----------------------- ...
> ... Removing previously used \.cpan\build\Crypt-SSLeay-0.57\.
> Going to build D/DL/DLAND/Crypt-SSLeay-0.57.tar.gz
> ========================================================================
> No installed SSL libraries found in any of the following places.
>     c:\openssl
> You will have to either specify a directory location at the following
> prompt, or rerun the Makefile.PL program and use the --lib switch to
> specify the path. If the path in question is considered standard on your
> platform, please consider filing a bug report in order to have it taken
> into account in a subsequent version of Crypt::SSLeay.
> Which SSL install path do you want to use?  [I hit Return]
> ...
> ...
> Removing previously used \.cpan\build\Finance-Quote-1.13\.
> Going to build H/HA/HAMPTON/Finance-Quote-1.13.tar.gz
> Checking if your kit is complete...
> Looks good
> Writing Makefile for Finance::Quote
>      -- OK
> Running make test
> 'test' is not recognized as an internal or external command,
> operable program or batch file.
>     test -- NOT OK
> Running make install
>   make test had returned bad status, won't install without force
> ------------------------------>< snip ><---------------------------

Is this on Windows, as you indicated originally? It bears no resemblance 
whatsoever to what I get when I run the "install online price retrieval". 
There is no need to "accept defaults" as no prompts are issued; the whole 
thing just runs itself. Here is the start of the output:

* Check Perl

* Install DateManip

Downloading ActiveState Package Repository packlist...not modified
No missing packages to install

* Install Crypt-SSLeay

Downloading Crypt-SSLeay-0.53...done
Unpacking Crypt-SSLeay-0.53...done
Generating HTML for Crypt-SSLeay-0.53...done
Updating files in site area...done
Downloading Crypt-SSLeay-0.53 install script...done
Running Crypt-SSLeay-0.53 install script...
This software package uses strong cryptography, so even if it is created,

What version of Perl are you running? You appear to be fetching from CPAN 
rather than from ActiveState (and that's a later Crypt-SSLeay than I'm 

> Do I have to have an SSL library ?

The Perl installer should take care of that. (Though AFAIK, it should 
also refrain from trying to reinstall Crypt_SSLeay-0.53 given that it 
already did so last time I reran).

More information about the gnucash-user mailing list