Problem with custom reports

Jonathan Mizrahi mizrahi.jonathan at
Wed Jan 5 09:39:10 EST 2011

This is on Windows 7 64 bit.  The following 5 objects are on the chart:
income statement, income pie chart, expenses pie chart, assets pie chart,
and net worth bar chart.  Only the income statement and the income pie chart
display.  The other three display only an error.

I tried remaking the report in 2.4.0 with only an income statement, income
pie chart, and expenses pie chart.  As before, the income statement and
income pie chart displayed, but the expenses pie chart did not display.

Thanks for your help!

On Tue, Jan 4, 2011 at 9:05 AM, Phil Longstaff <plongstaff at>wrote:

> This should be sent to the user list, not to me personally.
> So, your report has an income statement, 3 pie charts and 1 bar chart, and
> with 2.4.0, the income statement, 1 pie chart and 1 bar chart display, but
> the other 2 pie charts show "unable to display pie chart".  Is this correct?
> What platform?  Linux?  Windows?  Windows 7?  MacOSX?
> What specifically are the pie charts (expenses, income, assets)?  Which one
> shows and which ones don't show?
> What specifically is the bar chart?
> I'll try to reproduce in the next few days.  If this report is vital to you
> and you need it today, then yes, downgrade back to 2.2.9.  Otherwise, it
> sounds like we'll need 2.4.1 fairly soon to fix some of this kind of
> problem.
> Phil
> ---------
> I used to be a hypochondriac AND a kleptomaniac. So I took something for
> it.
> ------------------------------
> *From:* Jonathan Mizrahi <mizrahi.jonathan at>
> *To:* plongstaff at
> *Sent:* Tue, January 4, 2011 8:59:35 AM
> *Subject:* Problem with custom reports
> Hello,
> I just upgraded from Gnucash 2.2.9 to 2.4.0.  My custom report no longer
> works properly.  On my report I have an Income Statement, three pie charts
> and a bar chart.  In 2.4.0, two of the pie charts now won't display; instead
> I see "unable to display pie chart."  Also for the bar chart, I see "unable
> to push bar chart."  I tried remaking the report in 2.4.0, I had similar
> results.  Do I need to downgrade back to 2.2.9 in order to get my report to
> work again?
> Thank you,
> Jonathan Mizrahi

More information about the gnucash-user mailing list