GnuCash won't start

Derek Atkins derek at
Wed Jan 12 12:23:15 EST 2011


On Wed, January 12, 2011 12:06 pm, Linde B. wrote:
> Went to see where data files were, and didn't have an icon in the
> "Start Menu" folder, so I used the "Run" link to get a command line,
> went to gnucash, and chose this:
> "C:\Program Files\gnucash\bin\gnucash-bin.exe"
> ran it, and got the message:

You cannot do this!  If you're going to run GnuCash 2.2.x by hand you need
to run the gnucash.cmd file, not gnucash-bin.exe.

> gnucash-bin.exe - Unable To Locate Component
> This application has failed to start because libgncmod-engine.dll was
> not found. Re-installing the application may fix this program.
> <<

See above, you cannot run gnucash-bin.exe by hand.  You can run
gnucash.cmd, or go to Start -> All Programs -> GnuCash and run it from

> BTW, if I don't shut off OnDemand Scan from McAfee's VirusScan, it
> claims to find a couple of trojans in a couple of files for 2.4.0
> (is-GI4JC.tmp and another .tmp file) as "Artemis!9A183DF6E17F" -- I
> googled the file names and got nothing, and searched them in McAfee's
> virus info, and also got no hits, so I disabled On-Demand Scan for
> installation.

Which files does it complain against?  I've heard a few instances of this
already, and I'd like to track it down.  Could you send a list of the
affected files?

> I sent one of the developers a message via the Source Forge messaging
> function... I don't know enough to know whether that's significant or
> not.

You should send it to gnucash-user (or gnucash-devel), not to individual
sourceforge addresses.

> I thought I saw that the data files are in Documents and
> Settings\linde\.gnucash2 -- so I should copy / back up that to
> somewhere else?  And there are a ton of gnucash "lindesfinances..."
> files in \linde\...

.gnucash2?  Hmm, not sure about that.

> So I'm thinking I should uninstall 2.2.9 and reinstall...? 2.4.0?


> Thanks, y'all
> L
> Thanks...


> On Wed, Jan 12, 2011 at 10:36, Mike Leone <turgon at> wrote:
>> On 1/12/2011 11:25 AM, Derek Atkins wrote:
>> > "Linde B." <linde.brocato at> writes:
>> >
>> >> Yep, I tried the "file-->open" and also tried to find a log to run
>> from the
>> >> import menu.  none of it worked.  Perhaps now, after installing and
>> using
>> >> 2.2.9, if I uninstall it and install 2.4.0, might it find the data?
>> >
>> > Just remember where your data file is located...
>> And make another copy somewhere else, just to be doubly sure.
>> _______________________________________________
>> gnucash-user mailing list
>> gnucash-user at
>> -----
>> Please remember to CC this list on all your replies.
>> You can do this by using Reply-To-List or Reply-All.
> --
> Linde M. Brocato
> [Clock] Time is a human invention that allows for coordination and
> frame of reference stabilization. Conventional planners have lost
> track of that, and a few hundred years of industrialization and
> artificial manipulation of our relation to natural rhythms has made us
> forget it. -- Charlie Gilkey
> When machines and computers, profit motives and property rights, are
> considered more important than people, the giant triplets of racism,
> extreme materialism, and militarism are incapable of being conquered.
> . . . A nation that continues year after year to spend more money on
> military defense than on programs of social uplift is approaching
> spiritual death. -- Martin Luther King, Jr.
> Nothing in the world is more dangerous than sincere ignorance and
> conscientious stupidity. -- Martin Luther King, Jr.
> It is easier to build strong children than to repair broken men. --
> Frederick Douglass
> _______________________________________________
> gnucash-user mailing list
> gnucash-user at
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.

More information about the gnucash-user mailing list