Upgrading from 2.2.9 to 2.4.0 on Snow Leopard.

David T. sunfish62 at yahoo.com
Thu Jan 20 14:03:28 EST 2011

David, John--

There is something flickering in my memory about this... Perhaps there is a conflict between Fink and the Gnucash bundle. David, have you tried renaming /sw to something else, and then firing up Gnucash.app? 

I seem to recall that I was encountering troubles of this sort on my installation, and when I cleared out /sw, the problem went away. I never did anything else on this because I only had Fink for Gnucash. However, it seems to me that for long term peaceful coexistence, the Gnucash bundle needs to figure out how to work with Fink's modifications to the system path. 

John--I am not particularly expert on this, but when one installs Fink, we are instructed to run a shell script that rewrites the paths, and once that is done, Fink packages work. I suspect that this is where the problems crop up. While Fink *does* use an initialization script for the command line, I was receiving errors when running Gnucash.app (i.e., not from a command line). Since I was not going to the command line, I don't understand why or how the Fink init script was running.


--- On Thu, 1/20/11, David Bergum <dib at red-sky.us> wrote:

> From: David Bergum <dib at red-sky.us>
> Subject: Re: Upgrading from 2.2.9 to 2.4.0 on Snow Leopard.
> To: "John Ralls" <jralls at ceridwen.us>
> Cc: gnucash-user at gnucash.org
> Date: Thursday, January 20, 2011, 10:24 AM
> On Jan 20, 2011, at 12:10, John Ralls wrote:
> > A couple of things to try:
> > * killall dbus-daemon, then check to see if the Fink
> ones stay killed (if Fink adds it to launchd, then it will
> get restarted). If they do, try launching Gnucash
> I tried killall and the dbus-daemon processes from Fink
> restarted, so they must be in launchd.
> > 
> > * Comment out the section of
> Gnucash.app/Contents/MacOSX/Gnucash that start up dbus, and
> launch Gnucash. The idea here is that it might work if
> there's only one session dbus-daemon.
> I commented out the entire region dealing with dbus and
> uppon starting GnuCash I got the error:
>     "An error occurred while loading or
> saving 
>     configuration information for
> Gnucash-bin. Some
>     of your configuration settings may not
> work 
>     porperly."
> I quit out.
> > * creating a new user and launching Gnucash from that
> userid; that should isolate Gnucash from Fink .
> > 
> I get the same error in a new admin account with default
> Mac env, so it looks like the Fink dbus daemons are a
> problem?  
> I'm trying to find where dbus is started, but am not
> finding a plist for it anywhere.
> Dave
> David Bergum       
>         <dib at red-sky.us>
> 2415 Saint Pauls Square   
>     218-206-2133 Skype
> Raleigh, NC  27614   
>         612-723-7135 cell
> _______________________________________________
> gnucash-user mailing list
> gnucash-user at gnucash.org
> https://lists.gnucash.org/mailman/listinfo/gnucash-user
> -----
> Please remember to CC this list on all your replies.
> You can do this by using Reply-To-List or Reply-All.


More information about the gnucash-user mailing list