Scheme g2 install report

Derek Atkins warlord at MIT.EDU
Sat Feb 19 15:19:20 EST 2005

Neil Williams <linux at> writes:

> I've only just spotted this in my gnucash-gnome2-dev make install output:
> WARNING: failed to install schema 
> `/schemas/apps/gnucash/dialogs/commodities_dialog/quote_flag_visible' locale 
> `C': Unableto store a value at key 
> '/schemas/apps/gnucash/dialogs/commodities_dialog/quote_flag_visible', as the 
> configuration serverhas no writable databases.
> ...
> It's repeated many times.

I don't see this in my version.

> Is this a problem unique to me (i.e. the /etc/gconf/2/path setting I think it 
> mentions - it's too late, the rest has scrolled past now) or is this 
> something in g2?

I suspect this is just you.  I certainly don't see this using a
current build of g2-CVS.

> It's hard to spot as it's off the top of the terminal scroll by the time the 
> make install ends so I can't tell a whole lot more.

???  What does make install have to do with this?

> Is there some way of re-directing this stuff to a file (without all the gcc 
> output / commands)?
> Would this be the cause of GLib-GObject-CRITICAL and Gtk-CRITICAL messages on 
> starting g2?
> (gnucash:5015): Gtk-CRITICAL **: gtk_message_dialog_new: assertion `parent == 
> NULL || GTK_IS_WINDOW (parent)' failed
> I haven't had these on any previous runs of g2 and I haven't altered anything 
> in gconf that I can remember.

I see a few Gtk messages on startup, but not these.  I see:

(gnucash:13791): GLib-GObject-CRITICAL **: file gvaluetypes.c: line 741 (g_value_set_string): assertion `G_VALUE_HOLDS_STRING (value)' failed

(gnucash:13791): GLib-GObject-CRITICAL **: file gobject.c: line 1019 (g_object_set_property): assertion `G_IS_VALUE (value)' failed

(gnucash:13791): GLib-GObject-CRITICAL **: file gvalue.c: line 147 (g_value_unset): assertion `G_IS_VALUE (value)' failed

> I'm also getting pango warnings in the new file druid when selecting example 
> accounts to use.
> (gnucash:5015): Pango-WARNING **: Invalid UTF-8 string passed to 
> pango_layout_set_text()

I'm not seeing this here.  I just ran through the dialog and it worked
just fine for me.  No warnings at all.  I'm in the en_US.UTF8 locale,
if that makes any difference.

> Other than that, g2 runs as expected, just lots of warnings.

Well, we definitely need to fix those warnings.  :)
FWIW I just got a bunch of warnings from a report-options dialog.  I ran a
Trial Balance report and then clicked "Options", and then I got the

(gnucash:13791): GLib-GObject-CRITICAL **: file gsignal.c: line 1745 (g_signal_connect_closure_by_id): assertion `signal_id > 0' failed

(gnucash:13791): GLib-GObject-WARNING **: gsignal.c:1893: signal `changed' is invalid for instance `0xa4a4608'

(gnucash:13791): GLib-GObject-WARNING **: gsignal.c:1893: signal `changed' is invalid for instance `0xa4d64c8'

(gnucash:13791): GLib-GObject-WARNING **: gsignal.c:1893: signal `changed' is invalid for instance `0xa4e0778'


       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL:    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-devel mailing list