Compiling GnuCash on Windows

Derek Atkins warlord at MIT.EDU
Mon Dec 4 11:39:21 EST 2006

Huh, and that's the full backtrace?  That seems rather... limited..
Hmm.. How odd...  I wonder where the strcmp() is happening?

Have you tried updating and building with the current code?


"Brian Blatnik" <blatnik at> writes:

> Sorry took a while before I had the chance to run with gdb. Here's what
> happens when I try to save a file. Thanks for your help!
> In the gdb window:
> GNU gdb 5.2.1
> Copyright 2002 Free Software Foundation, Inc.
> GDB is free software, covered by the GNU General Public License, and you are
> welcome to change it and/or distribute copies of it under certain
> conditions.
> Type "show copying" to see the conditions.
> There is absolutely no warranty for GDB.  Type "show warranty" for details.
> This GDB was configured as "i686-pc-mingw32"...
> (gdb) run
> Starting program: C:\GnuCash\gnucash\bin/gnucash-bin.exe
> Program received signal SIGTRAP, Trace/breakpoint trap.
> 0x10024a00 in strcmp ()
> (gdb) bt
> #0  0x10024a00 in strcmp ()
> #1  0x00000000 in ?? ()
> (gdb)
> And in the gnucash-bin window:
> This is a development version. It may or may not work.
> Report bugs and other problems to gnucash-devel at
> You can also lookup and file bug reports at
> The last stable version was GnuCash 2.0.2
> The next stable version will be GnuCash 2.2
> gnucash: [E] "Failed to fork child process."
> (gnucash:5684): Gtk-WARNING **: file_system_win32=026C5B80 still has
> handle=0269
> 2F20 at finalization which is NOT CANCELLED!
> (gnucash:5684): GLib-GObject-WARNING **: invalid uninstantiatable type
> `void' in
>  cast to `GtkFileSystemWin32'
> (gnucash:5684): GLib-CRITICAL **: g_hash_table_lookup: assertion `hash_table
> !=
> NULL' failed 
> -----Original Message-----
> From: Christian Stimming [mailto:stimming at] 
> Sent: Thursday, November 02, 2006 9:29 AM
> To: Derek Atkins
> Cc: Brian Blatnik; gnucash-devel mailing list
> Subject: Re: Compiling GnuCash on Windows
> For me on win2000/SP4 with r15078 and the updated gnome packages according
> to the recent commits in, I get these:
>>> - Creating a new file (with default account hierarchy)
> Works for me just fine. The account hierarchy druid comes up and gives all
> the locale=C choices that are shipped with gnucash.
>>> - Creating more accounts in that file
> Works.
>>> - Adding transactions to these accounts
> Works.
>>> - running reports, particularly "account summary", "income 
>>> statement", "balance sheet"
> Doesn't work. I tried to run gnucash under gdb,
> , and surprisingly enough then it
> works! All of the text reports will simply work when running under gdb...
> sigh.
>>>- Saving to file
> Works just fine as well, probably due to the recent gtk upgrade.
>>>> Also, in the command prompt window is the following:
>>>> gnucash: [E] "Failed to fork child process."
>>> This is probably because gnucash tries to save the file in compressed 
>>> form, which requires a separate gzip process that won't work on 
>>> windows. In short, in the preferences please uncheck the checkbox 
>>> under General -> File -> Compress file. Does saving work, then?
>> I wonder if we should just disable this feature on win32?
> The feature is already disabled on windows, see io-gncxml-v2.c:1243. I tried
> to find the place that's causing this "failed to fork" message, but
> apparently it doesn't come from within gnucash. At least we don't have that
> string anywhere, and the only fork() that gnucash uses is in io-gncxml-v2.c
> which is unused on windows. So I have no idea where this comes from, and I'd
> simply ignore it for now.
> Christian

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL:    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the gnucash-devel mailing list