Bug in TXF Report? Gnucash 2.3.8 and 2.3.9

J. Alex Aycinena alex.aycinena at gmail.com
Tue Feb 9 20:35:13 EST 2010


On Tue, Feb 9, 2010 at 5:08 PM, Marc Ronell <mronell at verizon.net> wrote:
> Alex,
> Thanks for  looking at  the problem.  You  are correct.   This gnucash
> file was previously used with  version 2.3.3 where the tax report does
> work.
> I did go  into Edit->Income Tax Options and  selected 'Edit'.  I chose
> 'Individual,  Joint, etc.' and  entered a  Name.  Then  selected Child
> care  and set it  as Tax  related and  tried to  run the  Tax Schedule
> Report but it gave me the same error again.
> I am really surprised no one else has reported this issue.  Gnucash
> users must be real tax filing procrastinators. :)
> Thanks again,
> Marc

I'm surprised it didn't work for you after setting the 'Tax Entity
Type'. (By the way, the report does work for me, so maybe it works for
others that have tried it and that's why you haven't seen any
complaints; or maybe no one else has tried it.)

Let me try to fully understand. Before setting the 'Tax Entity Type'
as a result of my e-mail, it had not yet been set for this data file.
Is that correct?

Then you set it, hit 'Apply' for the dialog, selected Child Care and
set it as Tax  related with a code assigned and hit 'OK'. Then when
you ran the report you got the same "Report  error" on the report tab
and similar gnucash.trace output? Could you show me that second trace

On the 'Accounts' tab, do you have the 'Tax Info' column displayed? If
you display it, do you see an entry for the Child Care account? Are
there entries for any other accounts (you may have to expand the tree
to check)?

Is your data file saved as XML or in a database?

I look forward to you feedback.


More information about the gnucash-devel mailing list