[GNC-dev] [GNC] Reports have got broken with commit f66b7ed

John Ralls jralls at ceridwen.us
Fri Feb 14 17:59:45 EST 2020

> On Feb 14, 2020, at 10:33 AM, Peter Zimmerer <pkzw at web.de> wrote:
> Hi John,
> thanks for your prompt response.
> Am 14.02.20 um 18:34 schrieb John Ralls:
>>> On Feb 14, 2020, at 7:00 AM, Peter Zimmerer <pkzw at web.de> wrote:
>>> Hi all,
>>> if I build gnucash from commit f66b7ed (or a newer commit in maint) any
>>> report from the "Reports" menu will show up with an empty page.
>>> If I keep the report open and close gnucash the report will be displayed
>>> correctly after restart of gnucash.
>>> If I open a new report or a report from the "Saved Report
>>> Configurations" an empty page will show up again.
>>> A build from the previous commit 58ddb47 does not show this issue/behavior.
>>> Can anybody confirm this behavior?
>> It worked OK for me on Arch Linux with a fresh maint build just now. On what platform are you testing?
> I am on Debian 10.3 with Gnome desktop amd I am testing the newest
> version of Aqbanking and Gwenhyfar with Gnucash.
> I have just tried it with the most recent commit b23d244 from maint on
> Github and could reproduce the issue.
>> BTW, questions about builds from git are better directed to gnucash-devel than to here.
> Thanks for the info. I will use gnucash-devel now.

OK, I updated my Debian 10 VM and see the problem there. On a hunch I did a system update on Arch and now see the same problem.

Bob Fewell, this is about your "Follow up to previous commit 94cb965/Bug 797570" aka PR 644. In addition to the report not generating I get the following on the terminal when I open an SX editor window:
sys:1: Warning: ../../../gobject/gsignal.c:2523: signal 'page_changed' is invalid for instance '0x55a669b844d0' of type 'GncEmbeddedWindow'

John Ralls

More information about the gnucash-devel mailing list