g-wrap compiling prob

Alexander Klosch linux-lists at web.de
Wed Dec 17 07:09:02 CST 2003

hi derek, 

Derek Atkins <warlord at MIT.EDU> wrote:
:: Alexander Klosch <linux-lists at web.de> writes:
:: [snip]
:: > make[2]: *** [gw-standard.c] Segmentation fault
:: > make[2]: *** Waiting for unfinished jobs....
:: [snip]
:: > what can I do? I also tried previous versions of g-wrap and the
:: > gentoo ebuilds of g-wrap [which should be the same source], but the
:: > same problem in all versions. am I missing something?

:: Generally this implies a hardware problem.  So, I'd say "run
:: memtest86" and make sure your hardware is ok.  Turn off swap to make
:: sure your disk isn't causing the problem.  Or perhaps it could be a
:: compiler bug.

I tried memtest and different compiler versions and different g-wrap
I versions.
no luck at all. 
still getting:

make[2]: Entering directory
`/var/tmp/portage/g-wrap-1.2.1-r2/work/g-wrap-1.2.1/g-wrapped' guile -c
          "(set! %load-path (cons
          d/..\" %load-path))""(use-modules (g-wrap)) \
                        (use-modules (g-wrapped gw-runtime-spec)) \
                        (gw:generate-module \"gw-runtime\")"
ERROR: In procedure struct-ref:
ERROR: Wrong type argument in position ~A (expecting ~A): ~S
make[2]: *** [gw-runtime.c] Error 2
make[2]: Leaving directory
`/var/tmp/portage/g-wrap-1.2.1-r2/work/g-wrap-1.2.1/g-wrapped' make[1]:
*** [all-recursive] Error 1 make[1]: Leaving directory
`/var/tmp/portage/g-wrap-1.2.1-r2/work/g-wrap-1.2.1' make: *** [all]
Error 2

!!! ERROR: dev-libs/g-wrap-1.2.1-r2 failed.
!!! Function src_compile, Line 36, Exitcode 2
!!! (no error message)


More information about the gnucash-user mailing list