Building gnucash on OS X--enlightenment requested

Rich Johnson rjohnson at
Wed Nov 19 09:32:36 CST 2003

On Tuesday, November 18, 2003, at 10:43 PM, Derek Atkins wrote:

> Rich Johnson <rjohnson at> writes:
>> checking for g-wrap module directory... 
>> /sw/share/guile/1.6/g-wrap-1.3.4
>> checking if g-wrap works... ERROR: Could not find slib/require.scm in
>> ("/sw/share/guile/1.6/g-wrap-1.3.4" "/sw/share/guile/site"
>> "/sw/share/guile/1.4" "/sw/share/guile" ".")
>> configure: error: g-wrap could not run.  Perhaps missing slib?
> This implies you don't have slib installed.
Ah, but I do have slib installed--version 2d6-1.  But configure (or 
g-wrap) is unable to find the scheme library.

Information about 2425 packages read in 14 seconds.
  i   slib             2d6-1        Portable scheme library
      slib-gu14        2d6-1        Portable scheme library for guile
  i   slib-gu16        2d6-1        Portable scheme library for guile16

I waded through a fair number of google searches.  Since I wish to use 
default installations for as many components as possible,  I tried 
setting SCHEME_LIBRARY_PATH prior to running autogen, but that didn't 
work.  I finally opted to _manually_ create the link 

guile status:    
building gnucash: (check 
out point 2.)

The only other thing I ran into I had was that the Berkey DB package 
db4 isn't listed in the README as a dependency.

At this point I'm configured and dealing with minor compilation errors:
- deprecated atoll() vs strtoll()
- "`scm_num2long' makes integer from pointer without a cast".

The bottom line is that building the CVS HEAD on Mac OS X/Darwin 
requires the following:

Recognize that the installation tree descends from "/sw"
Dependencies not required by 1.8.7:   db4
Installation tree modification:  ln -s /sw/share/slib /sw/share/guile/
Environment variables set _before_ running

All-in-all, a pretty short list :)


More information about the gnucash-user mailing list