Compilation problem (solved) on 1.8.12 for Ubuntu/Debian systems

Jordan Erickson jerickson at
Mon Feb 20 18:23:15 EST 2006

Hello all,

I just wanted to record a problem (and solution) for compiling 1.8.12 
under Ubuntu 5.10 (Breezy) - Simmilar versions and Debian should be 
simmilar. I saw a few simmilar unanswered  posts a from while ago in 
this list when researching my problem.

Anyway - ./configure yilded to me:

checking for gtkhtml >= 1.1... yes
checking for gtk_html_new in -lgtkhtml-1.1... no
configure: error: Cannot link gtkhtml-1.1. See the README and config.log 
for more info.

ALL gtkhtml-dev packages were already installed. After a few hours of 
scratching my head and apt-getting anything related to gtkhtml I dug 
into config.log and then saw that ld was querying gtkhtml through gconf 
(sorry if that sounds off, i'm not a programmer). So I installed 
libgconf-dev (which in turn installed liboaf-dev), and ./configure 
passed the check.

Hope this helps some other people that might have the same problem, as 
it's not incredibly obvious which dev packages are necessary to compile 

- Jordan

More information about the gnucash-user mailing list