Upgrading from 2.2.9 to 2.4.0 on Snow Leopard.

David Bergum dib at red-sky.us
Thu Jan 20 13:24:56 EST 2011

On Jan 20, 2011, at 12:10, John Ralls wrote:

> A couple of things to try:
> * killall dbus-daemon, then check to see if the Fink ones stay killed (if Fink adds it to launchd, then it will get restarted). If they do, try launching Gnucash

I tried killall and the dbus-daemon processes from Fink restarted, so they must be in launchd.

> * Comment out the section of Gnucash.app/Contents/MacOSX/Gnucash that start up dbus, and launch Gnucash. The idea here is that it might work if there's only one session dbus-daemon.

I commented out the entire region dealing with dbus and uppon starting GnuCash I got the error:

	"An error occurred while loading or saving 
	configuration information for Gnucash-bin. Some
	of your configuration settings may not work 

I quit out.

> * creating a new user and launching Gnucash from that userid; that should isolate Gnucash from Fink .

I get the same error in a new admin account with default Mac env, so it looks like the Fink dbus daemons are a problem?  

I'm trying to find where dbus is started, but am not finding a plist for it anywhere.


David Bergum				<dib at red-sky.us>
2415 Saint Pauls Square		218-206-2133 Skype
Raleigh, NC  27614			612-723-7135 cell

More information about the gnucash-user mailing list