[GNC] "?" symbol pre fixed with all balances in my account balances

Adrien Monteleone adrien.monteleone at lusfiber.net
Fri Dec 13 12:02:58 EST 2019

I’m not versed on settings.ini syntax, but you might need to quote the font name so it doesn’t see it as 2 fonts. ("Calibre 14" instead of “Calibre" and “14")

Also, check your currency list in GnuCash and the assigned symbol for Rupee there. It is possible to customize the unicode glyph. The wrong one might be assigned. Finally, you also might find it easier to either change your Windows locale currency (if that works for you) to Rupee, or else try to assign a 4th or 5th level keyboard key to the Rupee so you can type it without needing the ALT+x method. (you would use the ALT key with some other like CTRL in a combo) 

Finally, GnuCash uses GTK+ and not the Windows UI directly. GTK+ does not support the ALT+x input method. (which is Windows specific) It does support entering Unicode hex codes though. See this: https://en.wikipedia.org/wiki/Unicode_input#In_X11_(Linux_and_Unix_variants)


> On Dec 13, 2019 w50d347, at 4:56 AM, Keshava M P <keshava.mp at gmail.com> wrote:
> I tried the same.
> First I ran a query in Google "fonts that support Rupee symbol".  Got
> confirmation that now windows came with support for Rupee symbol and we
> could directly type rupee in applications like say Word - by typing 20b9
> followed by Alt+x. So, by this logic, I thought if I change in settings.ini
> (gnucash on windows 10), this problem would be solved. Here is my
> settings.ini:
> [Settings]
> gtk-xft-antialias=1
> gtk-xft-hinting=1
> gtk-xft-hintstyle=hintfull
> gtk-xft-rgba=rgb
> #introduced by MPK for rupee symbol
> gtk-font-name=Calibri 14
> But still, no luck. Any suggestions?
> Thanks for your help.
> Regards,
> Keshava

More information about the gnucash-user mailing list