[GNC] Gnucash terminal commands not working & e-mail reply to all

David H hellvee at gmail.com
Thu May 13 20:16:41 EDT 2021

No probs and yes as per Stan's email reply to all means send 1 reply to the
mailing list so everyone subscribed to the mailing list will see a copy.
Helps others as well that may be having the same problem.

Yes the "\" is an escape character, basically means treat it as a space
:-)  You have a space in the app name i.e. "Gnucash 4.4-2" as opposed
to "Gnucash4.4-2".   I think from memory placing double quotes around the
complete name also works i.e. "/Applications/Gnucash
4.4-2/Contents/Macos/xxxx" in which case you don't have to escape the space

Cheers David H.

On Fri, 14 May 2021 at 09:30, <smada46 at hotmail.com> wrote:

> Dave,
> Thanks for the info.  Fixed my problem.  Copying and pasting what you sent
> did not work immediately, but your instructions to right click the
> gnucash.app in Finder, Show Package Contents allowed me to see the path.
> It then dawned on me that I have two versions of Gnucash in the
> Applications folder and needed to specify which one.  After a few trial and
> errors putting the program number of Gnucash in (4.4-2) and it not working,
> I double clicked on one of the executable files in Contents/MacOS and the
> resulting Terminal window showed that I needed a backslash and space in
> front of the version of Gnucash i.e. /Applications/Gnucash\
> 4.4-2/Contents/Macos/xxxx.  Now works fine.  Thanks for the help.
> I know you said you don’t use my e-mail program, but got to thinking my
> interpretation of what is requested is wrong.  In other words, does reply
> to all mean to everyone subscribed to the Mail List (
> gnucash-user at gnucash.org) and not just to those who are responding on the
> specific string for the specific topic I am responding to?  If the former,
> it is an easy copy/paste of gnucash-user at gnucash.org.  Thanks again for
> the help.
> On May 12, 2021, at 20:03, David H <hellvee at gmail.com> wrote:
> Assuming you installed gnucash in your usual applications folder, in a
> terminal window (zsh) try ....
> /Applications/Gnucash.app/Contents/MacOS/gnucash-cli
> /Applications/Gnucash.app/Contents/MacOS/gnucash --version
> You can see & expand these paths by right clicking on gnucash.app in
> Finder and clicking "Show Package Contents" and then expanding the various
> folders to find these...
> Can't help with your email issue as I don't use it :-)
> Cheers David H.
> On Thu, 13 May 2021 at 11:35, <smada46 at hotmail.com> wrote:
>> Using Mac OS 10.15.7, Gnucash 4.4-2, F:Q 1.47 Aqbanking ? (whatever came
>> with GC 4.4)
>> First, I am not a computer person and know just enough to get myself in
>> trouble.  I have used the commands in the wiki to test finding GC version,
>> Aq banking version, to get quote for XAU, and to open GnuCash from the
>> terminal.  For the versions I would get “command not found”; and to open
>> GnuCash I got “unable to find application GnuCash.   The commands and
>> results are as follows:
>> dwa1:~ dwa1$ gnucash --version
>> -bash: gnucash: command not found
>> dwa1:~ dwa1$ aqbanking-cli versions
>> -bash: aqbanking-cli: command not found
>> dwa1:~ dwa1$ flatpak run --command=sh org.gnucash.GnuCash
>> -bash: flatpak: command not found
>> dwa1:~ dwa1$ cd gnucash
>> -bash: cd: gnucash: No such file or directory
>> dwa1:~ dwa1$ cd \applications\gnucash
>> -bash: cd: applicationsgnucash: No such file or directory
>> dwa1:~ dwa1$ cd \applications
>> dwa1:applications dwa1$ gnucash --version
>> -bash: gnucash: command not found
>> dwa1 at dwa1 ~ % gnc-fq-dump -v alphavantage XAU
>> zsh: command not found: gnc-fq-dump
>> dwa1 at dwa1 ~ % cd applications
>> dwa1 at dwa1 applications % gnc-fq-dump -v alphavantage XAU
>> zsh: command not found: gnc-fq-dump
>> dwa1 at dwa1 applications %
>> dwa1 at dwa1 ~ % cd applications
>> dwa1 at dwa1 applications % open -a Gnucash --args Our GnuCash Data.gnucash
>> Unable to find application named ‘Gnucash'
>> I tried changing directories to the application directory where GC is to
>> see if that helped.  Also between the first series and the second I changed
>> the shell that terminal said I should be using (from bash to zsh whatever
>> that means)
>> I looked through the wiki and help manual and didn’t find anything that
>> helped.  Also tried going through mail list archives.  What am i missing?
>> Second point is “reply to all” in an e-mail series on the mail list.  I’m
>> using the MAC mail program V13.4.  In normal e-mails I can hit reply to
>> all, but with the mail list when I double click to bring up an e-mail to
>> respond to, the reply to is greyed out.  In order to send to all in the
>> string I would have to copy and paste each e-mail address in my e-mail.
>> Again, what am  I doing wrong?
>> These are probably some basic computer things that I don’t know and may
>> be wasting your time and if so I apologize.  Thanks for any help.
>> _______________________________________________
>> gnucash-user mailing list
>> gnucash-user at gnucash.org
>> To update your subscription preferences or to unsubscribe:
>> https://lists.gnucash.org/mailman/listinfo/gnucash-user
>> If you are using Nabble or Gmane, please see
>> https://wiki.gnucash.org/wiki/Mailing_Lists for more information.
>> -----
>> Please remember to CC this list on all your replies.
>> You can do this by using Reply-To-List or Reply-All.

More information about the gnucash-user mailing list